Supported platforms

Server

 

Recommended

Supported

Server OS

Red Hat Enterprise Linux 7

Ubuntu 18.04 LTS

SUSE Linux Enterprise Server 12

Linux Debian 7+, (8+ from Nextcloud 16)

SUSE Linux Enterprise Server 12

Red Hat Enterprise Linux (or Centos) 6.9 and 7

Ubuntu Linux 16.04 LTS, 18.04 LTS

FreeBSD 12+

Web server

Apache 2.4 + PHP-FPM

Apache 2.4 + mod_php

Apache 2.4 + PHP-FPM

NGINX 1.12 + PHP-FPM

PHP

7.3

7.1

7.2

7.3

Database

MariaDB 10.4

MySQL 8.0

MySQL 5.6+

MariaDB 5.5, 10.1+

PostgreSQL 9.4+

Oracle 11, 12

 

Client

 

Supported

Desktop

Windows 7, 8, 10

macOS

Linux

Mobile

Android 4+

iOS 10.0+

Browser

Firefox

Chrome

Edge

Internet Explorer 11

Safari

 

All versions actively supported by the vendor

 

Minimum requirements for older versions

 ownCloud/Nextcloud version
 min/max PHP version
 min. MySQL version
min. MariaDB version min. PostgreSQL version
ownCloud 8 5.4.0 / ??
     
ownCloud 9 ?? / ??
     
ownCloud 10 ?? / ??
     

Attached Files
There are no attachments for this article.